HSI, HTAR and Transfer Agent News

Annoucing HSI 5.0.0.p1, TA 3.0.0

(05/23/2014)


HSI Version 5.0.0.p1 is now available for HPSS Release 7.4.x sites.  This version primarily contains changes to support HPSS 7.4 features such as IPV6 and 64-bit HPSS libraries.


Transfer Agent 3.0.0 is now available for HPSS Release 7.4.x.  This version adds 64-bit support, and 64-bit options for building the libraries and agents.


Compatibility


Older clients for HPSS 7.3 and earlier systems are NOT upward compatible and will not work with an HSI 5 gateway server, due to changes made in the I/O protocols in order to support IPV6.  


Availability


HSI 5.0.0.p1 is available for sites that have a valid HPSS license - contact your IBM support representative for help in obtaining the package.   Sites that have a support agreement with Gleicher Enterprises can obtain the code by contacting Michael Gleicher.


New Features in 5.0.0

New features in this release include:


HSI Major Changes in 5.0.0.p1:


■ Support for IPV6  

■ Replacement of older ai_threads package with pthreads

■ Ability to direct xferlog transfer messages to syslog



HTAR Major Changes in 5.0.0:

■ Support for IPV6

■ Replacement of older ai_threads package with pthreads


HSI 5.0.0.p1 contains changes for problems that have been encountered since the initial release

of HSI 5.0.0 for HPSS 7.4.1, as well as bugs that were reported for earlier HSI releases.  The

complete list of changes for this release can be found here.


HPSS Requirements for HSI 5.0.0

 ■ HPSS 7.4.1 or 7.4.2 or later is required for HSI 5.0.0 and beyond.  

 ■ The HSI checksum feature makes use of the HPSS "userattrs" table, which must be sized appropriately for the site's

    expected use of this feature.


Prerequisites for HSI 5.0.0

 ■ openssl-0.9.8g or higher is required for both the HSI Gateway and for all clients

 ■ the Editline Library (libedit) is required in order to build HSI with the history and command line editing functions enabled.

 ■ kerberos is required for both the HSI Gateway and for all clients if Kerberos authentication is to be used.


Configuration Changes

■ A new option “Xferlog Facility” was added to the server-side HPSS.conf file to optionally specify the syslog facility to be

used for xferlog messages when the server is configured to use syslog for audit trail and transfer log messages.


Compatibility

 ■ Older clients (all versions prior to 5.0.0) are incompatible with the 5.0.0 gateway server.  The I/O protocols were changed

in HPSS version 7.4 to support both IPV4 or IPV6.

 ■ HSI 5.0.0 clients require a 5.0.0 HSI Gateway server.

Obtaining The 5.0.0.p1 Release


The HSI source code is available, subject to the restrictions on protection of the source code, to all HPSS sites with a 

current HPSS license.  The HSI source code is only available to HPSS administrators, who are responsible for protecting the

code, and for building binaries for any of the supported platforms. Binaries may be freely distributed by whatever means

the site chooses (for example, via a web download page) to their user community.

Check with your HPSS site representative for more details.


For sites with a support agreement with Gleicher Enterprises, the HSI 5.0.0.p1 package may also be obtained by contacting Michael Gleicher (see link at the bottom of this page).


Documentation

The new features and commands are documented on the pages in this web site.  The updated hsi man page is also available as a tar file on the Downloads page.


Announcing HSI 4.0.1.3.P2

(05/23/2014)


HSI Version 4.0.1.3.P2 is now available for HPSS Release 7.3.x sites.  


Note: 4.0.1.3 was the last release with new HSI/HTAR features for HPSS 7.3 . Only bug fixes will be added starting with the 4.0.1.3 release.   HSI 5.x for HPSS 7.4.1 and beyond is now available - please see the announcement.


4.0.1.3.p2 contains bugfixes for problems that have been identified in the 4.0.1.2 and 4.0.1.2.p1 releases, and we encourage all HPSS 7.3 sites to upgrade to the new version.  A list of the changes in this release can be found here.

 

A list of older release notes can be found here.