Version 4.0.1.2.p1 Release Notes


4.0.1.2 Patch 1 changes


HSI


- make_cos.pl changes to support old-style or new-style lshpss output


- for cp command, fix incorrect "cannot overwrite" error detected 

  due to missing <break> statement in switch


- support -O srcofs:sinkofs:length option on get to piped file if  

  output offset = 0.


- warning message is erroneously issued on unrecovered EIO local  

  file write error


- fix funcName string in hsi_LFX_TA_XferHandshake


- fix statstruct.h typo - change _LAREGFILE64_SOURCE to

  _LARGEFILE64_SOURCE


- don't create local directories or copy symbolic links for 

  recursive hashverify/hashcreate


- for UDA creation, use file mod time as current time to avoid clock 

  skew 


- support cksum_enabled/cksum_type hsirc specification in site stanzas


HTAR


- (GHI-HTAR) do not unlink existing GHI archive file, force position to offset 0


- (GHI-HTAR) add dm_sync_by_handle call on successful extract


- (GHI-HTAR) Make "-o indexord" on param file mandatory for GHI extract operations


HSI Gateway


 - Fix wrong pathname in hsigwd_mapfile.c error message


 - Clarify reason for error message for lines w/missing token in mapfile

 

- Display application name that created checksum hash in hashlist instead of [HSI]


- Fix problem in "mkdir" command with default override of the SETGID  

  flag propagated from the parent. Require -m to do this now.


- fix missing % in hsi_LogMessage format


- Support use of getspnam() to get encrypted password from shadow

  password file in hsigwd_GASAPI_wrappers.c for non-AIX system 


HSI New Features in 3.5.3

■ Add "set agentcount=count option for specifying the number of Agents to be used 

for file transfers

■ Add -s stream_id option to the CHCOS command to specify a particular chcos stream ID to be

used.


HSI New Features in 3.5.2

■ Improve seed value for HPSS Request IDs

■ Preserve HPSS Perms for Directories on recursive gets

■ Internal code rework to speed up directory listings


HSI New Features in 3.5.1

■ Include current account ID in xferlog messages

■ Use auto-cos selection for "touch" command if not specified on the command line

■ Add -a, -c, -f, -m, -r, -t and -l options to the CHCOS command 

■ Use HPSS_CFG_FILE_PATH when looking for the global hsirc file

■ Add "enable_ta_io" to hsirc file to enable or disable use of the HPSS Transfer Agent

■ Add support for multiple CHCOS threads in the HPSS Core Server.  Automatically uses the maximum number

of threads, but provides overrides for the maximum number of threads to use. 


HSI New Features in 3.5

■ Support for HPSS 7.1  - HPSS 7.1 64-bit definitions, address structure changes for IPV4/IPV6

■ New "ls" listing options:

       "ls -Ln" listing option to specify the hierarchy level for "ls -P" listings

       "ls "-D" option to display full date/time

       "ls "-S" option to display size in KB/MB/GB/TB/PB/XB

■ Support server-side umask setting  for default umask if not overridden by hsirc

■ Support HPSS Transfer Agent for HPSS 7.x


HTAR New Features in 3.5.4:


 CSH-Style wildcard support added  for all commands to allow for using pattern-matching when selecting

files

■ Added support for "~" and "~user" HOME-directory syntax  when specifying pathnames for the archive file 

or for member files

■ Improved CPU use during I/O transfers  by changing select() calls to use the minimum fd count

■ Added "norecurse" command line option (-Hnorecurse) for disabling recursive scanning of directories and

recursive listing of directories


HTAR New Features in 3.5.3

■ Add new capabilities for GHI-HTAR


HTAR New Features in 3.5.2

■ Add -N fifofile option to provide HTAR heartbeat status for GHI/NFT/...


HTAR New Features in 3.5.1

■ 3.5.1 .0.contains no new features, just bugfixes

Prerequisitess for HSI 3.5.4

 ■ HPSS 7.2.1 or later is required for HSI 3.5.4.  

 ■ openssl-0.9.8g or higher is required for both the HSI Gateway and for all clients

 ■ the Editline Library (libedit) is required in order to build HSI with the history and command line editing functions enabled.

Compatibility

 ■ HSI 3.5,3.5.1,3.5.2,and 3.5.3 clients are compatible with an 3.5.4 HSI Gateway server

 ■ HSI 3.5.4 clients require a 3.5.4 HSI Gateway server